SQL Error

Discussion in 'Installation and Updates' started by asia, Jun 2, 2006.

  1. asia

    asia New Member

    Hello,

    I got this sql error.

    Does anyone know how to fix it?

    You have an error in your SQL syntax near '(SELECT t1.*, COUNT(DISTINCTROW t4.`id`) num_links, '0' `crossed`, t21.`num_cols' at line 1
  2. Vasily B.

    Vasily B. Administrator Staff Member

    Welcome to our support forums, asia
    Please check your MySQL version. We require MySQL 4.0 or above. It seems you have 3.23 version.
  3. asia

    asia New Member

    I updated mysql to version 4 and now it worked.

    I placed eSyniCat in /directory/ (subfolder).


    To display the eSyniCat, I'd need to url http://www.mydomain.com/directory.

    How grab the categories part and place it in root /index.php as I dont want to move eSyndiCat from /directory (httpdocs/directory) to root doc (httpdocs)?
  4. Nick Collins

    Nick Collins Guest

    Hello asia! I would advice you to install script again to the root directory on your server and then simply import categories from your old DB via phpMyAdmin.

    Here is a theoretical way to achieve your needs without moving of script files or fresh installation (I didn't test it myself):

    ***move .htaccess file from "directory" folder to the ROOT***
    ***find mod_rewrite rules for categories pages***
    Code:
    # mod_rewrite rules for categories pages
    RewriteRule ^(.*)/$ index.php?category=$1 [QSA,L]
    RewriteRule ^(.*)/index([0-9]+).html$ index.php?category=$1&page=$2 [QSA,L]
    ***and replace with***
    Code:
    # mod_rewrite rules for categories pages
    RewriteRule ^(.*)/$ dir/index.php?category=$1 [QSA,L]
    RewriteRule ^(.*)/index([0-9]+).html$ dir/index.php?category=$1&page=$2 [QSA,L]
    Make the similar changes with other rules. Then open your admin cp and go to "General Configuration". Remove "/directory" in "Base URL to script" field. Save changes.
    Hope it will help, but pay attention please to my advice at the top of this post.
  5. asia

    asia New Member

    It was working fine when I left it in /directory folder.

    I followed the above instruction and put it in ROOT with the changes made in .htaccess file. Now I cannot go to the categories, privacy page, contact page, terms page, and etc pages.

    Is there something wrong with the mod rewrite?
  6. asia

    asia New Member

    There is definitely something wrong with mod rewrite. I had to disable mod rewrite in the admin config area to get the script work. I will wait to see if you have a solution to solve this mod rewrite and I want to enable it.
  7. Sergey Ten

    Sergey Ten <b>eSyndiCat Lead Developer</b>

    Hello asia,

    I think you need add this code in your .htaccess file

    Code:
    RewriteBase /your_dir/
    
  8. asia

    asia New Member

    I am not sure what you mean by /your_dir/.


    path to www directory: /home/httpd/vhosts/mydomain.com/httpdocs


    I placed all files to /httpdocs, which is my root www folder.


    What do you want me to put for your_dir
  9. Sergey Ten

    Sergey Ten <b>eSyndiCat Lead Developer</b>

Share This Page