eSyndiCat 2.3.03 Released! Recommended!

Discussion in 'Announcements' started by Vasily B., Apr 14, 2010.

Thread Status:
Not open for further replies.
  1. Vasily B.

    Vasily B. Administrator Staff Member

    Greetings,

    We are happy to announce release of 2.3.03 version.

    BUGFIXES:

    #1. Admin Panel(p.el is undefined Portal.js (line 107)) fixed.
    #2. Implement improved chars counter for ckeditor.
    #3. Redirect user to login page when he uses ajax queries and if admin expire time is over.
    #4. Add comma to hooks to have ability add a few hook with the same code.
    #5. Image uploader in CKEditor fixed.
    #6. Checking extension of image file issue if a extension of image in upper case
    #7. The cleancss template is used by default. But there are not all block positions in configuration.
    #8. Can't uncheck plans in manage listing field page when I edit listing field I can't uncheck plan
    #9. Add file attribute to hook tag if file attribute exists then try to include it.
    #10. Image Gallery. Allow user to add more images to listing he has.
    #11. Listings navigation bar bug fixed.
    #12. Please display number of minimal symbols on suggest listing for description field if set option minimal symbols.
    #13. Suggest Listing. After changing some category plan selection changes too.
    #14. Image Gallery field. You can not delete a image from gallery field on the edit listing page.
    #15. Image Gallery field. The script did not create original images for gallery if you did not set width and height for image in configuration gallery field
    #16. Add asterix to required listing fields.
    #17. Problem with recurring payment plans fixed.
    #18. New Account. Sent email is wrong.
    #19. After uploading category icon form progress keep on loading.
    #20. Do not display field on view listing page if user does not insert information.
    #21. The listing details URL is invalid if mod_rewrite module is turned off.
    #22. Add attribute auto-complete off in search input


    NEW FEATURES AND IMPROVEMENTS
    #1. Add ability to use watermark to any uploaded images
    #2. Lower and Upper case URLs
    #3. Block default collapsed state.

    Patch is easy to apply. Here are the steps to perform upgrade to 2.3.03 version from 2.3.02.

    CREATE BACKUPS OF YOUR FILES AND DB

    1. Download patch and unpack it.
    2. Upload files from updates/ directory to your updates/ directory.
    There are two files in that directory:
    pre_upgrade_2.3.02_2.3.03.sql
    post_upgrade_2.3.02_2.3.03.sql

    3. Go to admin panel -> Manage Database -> Import. Import pre_upgrade_2.3.02_2.3.03 file.
    4. Upload all the files from patch to your working copy
    5. Run post_upgrade_2.3.02_2.3.03 update script using Admin Panel -> Manage Database -> Import functionality.

    That's all :) Your patch should be successfully applied. Anyway, you are always welcome to ask in case you have any questions.
  2. Bobby01

    Bobby01 Paid Customer

    First impression

    Installation on http://localhost system xampp
    errors log:
    WARNING: file_get_contents(http://tools.esyndicat.com/update.php?current=2.3.03&amp;domain=) [<a href='function.file-get-contents'>function.file-get-contents</a>]: failed to open stream: HTTP request failed! [ 14 Apr 2010 16:12:22 ] in I:\serwer\xampp\htdocs\eSyndiCat2.3.03\includes\classes\admin\esynUpdate.php:164
    WARNING: mysql_connect() [<a href='function.mysql-connect'>function.mysql-connect</a>]: Access denied for user 'username'@'localhost' (using password: YES) [ 14 Apr 2010 16:25:46 ] in I:\serwer\xampp\htdocs\eSyndiCat2.3.03\includes\classes\eSyndiCat.php(362) : eval()'d code:7
    WARNING: mysql_connect() [<a href='function.mysql-connect'>function.mysql-connect</a>]: Access denied for user 'username'@'localhost' (using password: YES) [ 14 Apr 2010 16:26:14 ] in I:\serwer\xampp\htdocs\eSyndiCat2.3.03\includes\classes\eSyndiCat.php(362) : eval()'d code:7:smoke::bue:
  3. Greg

    Greg Moderator

    When you get the chance, please post the template changes.
    :)
  4. ionutpuscasu83

    ionutpuscasu83 Paid Customer

    Upgrade from 2.3.02 to 2.3.03

    Hi,

    Can someone please explain how can you upgrade from version 2.3.02 to 2.3.03.
    Do I have to reinstall ? or there is a more commode way ?

    2. The Template Fireandice from version 2.3.02 is compatible with v2.3.03 ?

    Regards,
    Ionut
  5. clickme4

    clickme4 Paid Customer

    Simon explained how to upgrade in his post above
  6. ionutpuscasu83

    ionutpuscasu83 Paid Customer

    I sow the area where Simon explain how to apply the upgrade, but there are a lot of things that I don't get it: like

    1. Download patch and unpack it.
    The patch is the whole script? I mean the one that I get it when I download version 2.3.03 ?

    4. Upload all the files from patch to your working copy
    What do you mean by "to your working copy" ?! To upload all the script for 2.3.03 over the one installed ?

    The most important thing is : Are the templates affected by this upgrade ?
    I mean if i modified a template (some css and tpl files) it will still work ok both the site and the template ?

    Regards
  7. Vasily B.

    Vasily B. Administrator Staff Member

    There are two versions available. If you download CORE version it already includes 2.3.03 patch. There is also Patch in Downloads -> Misc section. It includes changed files only since 2.3.02 release. So I suppose you need to use that patch.

    Exactly.

    There are two files affected by this patch. header and footer.tpl. Eugene will post a list of changes for the 2.3.03 version.
  8. teelicious

    teelicious Paid Customer

    I just bought the stable version 10 days ago, do I need to do this update?
  9. EvilKukka

    EvilKukka Paid Customer

    It was released 3 days ago, so yes.
  10. Bobby01

    Bobby01 Paid Customer

    If you start building directory, and suggested I install the new fresh version v2.3.03 without updating
  11. teelicious

    teelicious Paid Customer

    Probably an oversight on my part, but where do you download the patch? Or do I just re-download the whole product?
  12. teelicious

    teelicious Paid Customer

    My directory is just about done, so I need just the update so I don't have to rebuild... where do I find that?
  13. Bobby01

    Bobby01 Paid Customer

  14. davidallen

    davidallen Kifaru

    Must be missing something

    Ok at the risk of sounding very stupid - if I download the upgrade where do I find it to unpack it and how do I unpack it?

    Please humour me and give me some detailed guidance

    Thanks
  15. smartpc

    smartpc Paid Customer

    davidallen..

    Before upgrading backup your db and files -
    http://www.esyndicat.com/forum/showthread.php?t=13951

    goto the downloads section (top menu) select misc you will find upgrade packs.

    Download appropriate zip file or all depending on version upgrade requirements.

    2.3.0 to 2.3.1 to 2.3.2 to 2.3.3 upgraded in order

    unpack zip - upload folder 1 level deep is the root folder - upload ftp files to appropriate folders etc.. be careful when uploading files you have previous modifications in

    when all files are uploaded you will need to apply sql patch in your esy admin area database import...select patch from updates folder dropdown - click go. Had problem upgrading 2.3.2 to 2.3.3 where couldn`t accesss the esyn admin panel after uploading files/ patch, so opened up the pre and post sql patches (updates folder) and changed prefix_blocks, config etc to v2300_blocks, v2300_config etc or your db prefix saved (thanks to Bobby) ,restored db and uploaded pre and post sql patches via phpmyadmin sql import...

    oh you may need an updated version of your template also if not using cleancss
    Last edited: Apr 19, 2010
  16. teelicious

    teelicious Paid Customer

    I followed directions on how to back up DB... however I guess I need also back up files... where do I go to do that... filezilla, myphp, in admin?? I need directions for that.

    Also as quoted above I may have problems updating since my site is build I guess?? Show should I not update? I don't want anymore problems, I'll never get my site launched.

    Also Also, if I may ask here since I'm asking, last week I added WP plugin, for some reason deleted it and now I went to re download it and it doesn't work. I noticed all the plugins for 2.3 stable say core version next to them, what does that mean?? Are they not compatible with stable version? Am I not adding them right? I'm trying to get a blog of my own to show on a page in my directory.

    Thanks
    Kelly
  17. Vasily B.

    Vasily B. Administrator Staff Member

    How to make backups!

    1. Backup consists of two parts - MySQL DB backup and files backup.

    How to make MySQL DB backup.
    Go to your phpMyAdmin -> Export. You will be able to download MySQL backup.
    If you have cPanel - there is an easier way to do that directly in control panel.

    How to backup files
    Use FTP to download all your files related to esyndicat. Keep them in separate folder on your PC. You can use FileZilla software for this

    It's more a patch, that has fixes for some bugs and few improvements. If you didn't modify your php files - I would recommend to upgrade your version and apply this patch. If you have some changes - you will need to reapply them on your new version files.

    Are you sure you configured it properly? You need to put DB details in the configuration when you install that plugin or you will have errors on your pages. Click on Installed Plugins tab and find that WP tools plugin and click Configure. Insert your correct WP DB details there.

    Closing this thread. If you have any questions regarding the upgrade process please ask in the appropriate forums.
  18. majnoon

    majnoon Paid Customer

    Simon can you please ask Eugene to post the template changes. I have a custom template and need to update it.
  19. Sergey Ten

    Sergey Ten <b>eSyndiCat Lead Developer</b>

Thread Status:
Not open for further replies.

Share This Page