404 error across all categories and sub-category.

Discussion in 'Installation and Updates' started by jameslittle, Aug 2, 2006.

  1. jameslittle

    jameslittle Paid Customer

    Hi ladies and gentlemen,
    I just installed esyndicat today. Very smooth, nothing hiccup in fact.

    However, after finished installation, I browsed thru my site to check out. I noticed that these has occured :-
    1. 404 error across all categories
    2. 404 error across all sub-category
    3. 404 error at few pages/links
    4. However, there are no errors encountered if the url is ending with ".php", eg :-
    I have double-checked the CHMOD persission setting for these :-
    1. templates/GreenLeaves/css/style.css ( I am using this template)
    2. includes/config.inc.php
    3. tmp
    4. backup
    All these files are CHMOD to 777 indeed.

    What should I do next?:bue:
    James
    PS- Apology I place a lot of links here. I'll delete them off after problems solved. This is just to give a clear idea of which links are having errors.
    Last edited: Aug 4, 2006
  2. Greg

    Greg Moderator

    Just a guess on my part James. But are you sure you uploaded the HTACCESS file and enabled mod_rewrite

    configs > General Configuration > Apache mod_rewrite module and check enabled
  3. Vincent Wright

    Vincent Wright New Member

  4. Greg

    Greg Moderator

    Vincent The only reason I didn't link to that article was I didn't know if you guys had made that section live yet. :)
  5. jameslittle

    jameslittle Paid Customer

    Ok, actually the "mod_rewrite" was enable when the errors occured!

    Now I have turn it off/disable it. And it just works! For example :-
    <links removed as problems has solved>
    Now I got reverse problem! :smoke: How do I get the url back to the orignal url path with "words" instead of current dynamic url?? It would be better to have static url with "keywords".

    I read the guides in your link, and I look thru my server info <link removed as problems solved> :-
    Is this showing that "mod_rewrite" in enable for my server?? What should I do to solve my problems?

    Thanks for guides
    James
    Last edited: Aug 4, 2006
  6. WTM

    WTM Loyal User

  7. jameslittle

    jameslittle Paid Customer

    I am using the "Pro v12" . I checked the .htaccess and I have added this too :-
    RewriteBase /

    Still having error, so I disable the "Apache mod_rewrite module" in my admin area. I searched thru this forum, andfound similiar thread that's still in progress :- http://www.esyndicat.com/forum/showthread.php?t=6385&highlight=.htaccess
    I believe I am having the same situation.

    Any further guides??:poisk:

    Thanks for your speedy reply.
    James
  8. WTM

    WTM Loyal User

  9. jameslittle

    jameslittle Paid Customer

    Hi WTM,
    You are fast !!
    Ok, I check my server, and it shows :-
    I believe my server is suitable for this script.^_^ Ok, I am having my own virtual dedicated server. I am using VPZZ and I manage it by myself. My server information as extracted from WHM :-
    Well, I only used 20% of resources available.

    Next step??:sos:

    Thanks!!:friends:
  10. WTM

    WTM Loyal User

    And you said your .htaccess file looks exactly like the one that came with the upgrade patch, except RewritaBase line, correct?
  11. jameslittle

    jameslittle Paid Customer

    Hi WTM,
    Ok, I re-upload all the files in my "public_html" folder where I installed the script, inclusive the .htaccess from patch. Now It works!!

    Just wonderful!! Now my directory site has se friendly url :-
    <link removed as problems solved>!!

    I love this!:p:kiss:

    Thanks WTM for your speedy guideances!:applause:
    James...the learning fellow...
    Last edited: Aug 4, 2006
  12. WTM

    WTM Loyal User

    You are welcome! ;)
  13. Vasily B.

    Vasily B. Administrator Staff Member

    off topic:
    hmm, I have just checked links in this thread and it seems our esyndicat looks very similar to phpBB %)
  14. WTM

    WTM Loyal User

    in what way???
  15. Vasily B.

    Vasily B. Administrator Staff Member

  16. WTM

    WTM Loyal User

    sure looks like a spam to me...
  17. jameslittle

    jameslittle Paid Customer

    Hi Simon and WTM,
    Nope, I was asking my data center to help after I read the knowledge base at : [FONT=Verdana, Arial, Helvetica, sans-serif] http://www.esyndicat.com/support/desk/index.php?_m=knowledgebase&_a=viewarticle&kbarticleid=1
    My help ticket to them :-
    [/FONT]
    [FONT=Verdana, Arial, Helvetica, sans-serif]

    [/FONT]
    ANd this is the reply I received from them:-
    If you were to check the link now, it has been adjusted back to esyndicat directory site.

    Regards.
    James
    PS - to put your mind in rest, I have removed all the links posted in this thread.
  18. WTM

    WTM Loyal User

    No problem, James.
    Have fun with the script!
  19. Vasily B.

    Vasily B. Administrator Staff Member

    It's ok :) Let us know if you have any problems with the script
  20. jameslittle

    jameslittle Paid Customer

    Hi guys,
    I simply love the script! Immediately after the site is up and running, I could see several pages has gained up to PR3 :- new-links, top-links, popular-links. I was both shock and happy !

    I will continue to explore further with your script.
    Thanks. Keep up the great script!
    James

Share This Page